Verified Commit bd391358 authored by AtjonTV's avatar AtjonTV
Browse files

Release 5.0.0

* Added
 * JsonKraken 2.0 dependency
 * `objectOutputStream` extension for File
 * `objectInputStream` extension for File
 * FFDB (FlatFile DataBase) (`klib.ffdb.FFDB`)
 * IncompatibleDatabaseException (`klib.exceptions.IncompatibleDatabaseException`)
 * `openFFDB` extension for String
 * `splitBy` extension for String
 * `trimSpace` extension for String

* Changed
 * Upgraded Kotlin from 1.3.61 to 1.3.71

* Removed
 * JsonKraken 1.0 Source
 * kSock (`klib.net.socket.kSock`)
 * Directory (`klib.files.Directory`)
 * `asDirectory` extension for File
 * Status number from `klib.files.Directory2.DirectoryError`

* Fixed
 * FFDB now checks if the File exists before writing/reading
 * FFDB now checks if the FIle is empty before reading
parent b7e766a9
Pipeline #2245 passed with stages
in 7 minutes and 18 seconds
......@@ -6,6 +6,15 @@ and this project adheres to [Semantic Versioning](semver.md).
## Unreleased
### Added
### Changed
### Deprecated
### Removed
### Fixed
### Security
## 5.0.0 - 2020-06-03 - Release 25
### Added
- JsonKraken 2.0 dependency
- `objectOutputStream` extension for File
......@@ -17,7 +26,6 @@ and this project adheres to [Semantic Versioning](semver.md).
- `trimSpace` extension for String
### Changed
- Upgraded Kotlin from 1.3.61 to 1.3.71
### Deprecated
### Removed
- JsonKraken 1.0 Source
- kSock (`klib.net.socket.kSock`)
......@@ -27,7 +35,6 @@ and this project adheres to [Semantic Versioning](semver.md).
### Fixed
- FFDB now checks if the File exists before writing/reading
- FFDB now checks if the FIle is empty before reading
### Security
## 4.1.0 - 25.02.2020 - Release 24
......@@ -390,7 +397,9 @@ and this project adheres to [Semantic Versioning](semver.md).
## Overview
* Unreleased - [Diff 4.0.0 to master](https://gitlab.atvg-studios.at/atvg-studios/kLib/compare/4.0.0...master)
* Unreleased - [Diff 4.1.0 to master](https://gitlab.atvg-studios.at/atvg-studios/kLib/compare/5.0.0...master)
* 5.0.0 - [Diff 4.1.0 to 5.0.0](https://gitlab.atvg-studios.at/atvg-studios/kLib/compare/4.1.0...5.0.0)
* 4.1.0 - [Diff 4.0.0 to 4.1.0](https://gitlab.atvg-studios.at/atvg-studios/kLib/compare/4.0.0...4.1.0)
* 4.0.0 - [Diff 3.2.0 to 4.0.0](https://gitlab.atvg-studios.at/atvg-studios/kLib/compare/3.2.0...4.0.0)
* 3.2.0 - [Diff 3.1.0 to 3.2.0](https://gitlab.atvg-studios.at/atvg-studios/kLib/compare/3.1.0...3.2.0)
* 3.1.0 - [Diff 3.0.0 to 3.1.0](https://gitlab.atvg-studios.at/atvg-studios/kLib/compare/3.0.0...3.1.0)
......
......@@ -14,6 +14,7 @@ Breaking versions must be in a new row!
| 2.0.0 | 2.1.1 |
| 3.0.0 | 3.2.0 |
| 4.0.0 | 4.1.0 |
| 5.0.0 ||
This means: `3.0.0` **IS upwards** compatible with `3.2.0` but **NOT downwards** compatible with `2.0.0`. (Semantic Versioning)
......
......@@ -5,12 +5,13 @@
| master | [![pipeline status](https://gitlab.atvg-studios.com/atvg-studios/kLib/badges/master/pipeline.svg)](https://gitlab.atvg-studios.at/atvg-studios/kLib/commits/master) |
| release/4.0.x | [![pipeline status](https://gitlab.atvg-studios.com/atvg-studios/kLib/badges/release/4.0.x/pipeline.svg)](https://gitlab.atvg-studios.at/atvg-studios/kLib/commits/release/4.0.x) |
| release/4.1.x | [![pipeline status](https://gitlab.atvg-studios.com/atvg-studios/kLib/badges/release/4.0.x/pipeline.svg)](https://gitlab.atvg-studios.at/atvg-studios/kLib/commits/release/4.1.x) |
| release/5.0.x | [![pipeline status](https://gitlab.atvg-studios.com/atvg-studios/kLib/badges/release/4.0.x/pipeline.svg)](https://gitlab.atvg-studios.at/atvg-studios/kLib/commits/release/5.0.x) |
kLib is a Generic Kotlin Library to simplify development
Checkout the Homepage over [here](https://klib.atvg-studios.com).
kLib is now available via a custom Maven repository.
kLib is available via the ATVG-Studios Maven repository.
You can find the Git repository that hosts the Maven data [here](https://gitlab.atvg-studios.com/atvg-studios/maven-repository).
The Maven Repository itself is available here: https://mvn.atvg-studios.com
......
......@@ -4,6 +4,7 @@
| Version | Supported |
| ------- | ------------------ |
| 5.0.x | :white_check_mark: |
| 4.1.x | :white_check_mark: |
| 4.0.x | :white_check_mark: |
| 3.2.x | :x: |
......
kotlin.code.style=official
# kLib Version
klib_version=5.0.0-dev.8
klib_version=5.0.0
# Versions
kotlin_version=1.3.71
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment